View unanswered posts | View active topics It is currently Mon May 20, 2019 7:21 pm



Reply to topic  [ 103 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11  Next
 HTC Vive support added to XStoryPlayer 3.5 
Author Message
Rank 6
Rank 6
User avatar

Joined: Sat Mar 02, 2019 5:57 am
Posts: 23
You don't need to rename the x64 exe to fix fluids. You need to rename the x64 folder. Most just add a digit or letter to the name, but anything will do. for example, mine is named "x64 (renamed to fix fluids)" :P


Thu Mar 14, 2019 8:08 pm
Profile
Rank 6
Rank 6

Joined: Thu Feb 18, 2016 6:51 am
Posts: 25
I know, that's how I disabled it. Problem is when you rename the folder VR won't work.


Fri Mar 15, 2019 1:54 am
Profile
Rank 6
Rank 6
User avatar

Joined: Sat Mar 02, 2019 5:57 am
Posts: 23
hmmm... I dont know. The attached screenshot is my file list of the root directory. (I just installed XSP fresh, applied the patch, and ran the game once to make sure it runs.)
you see the renamed folder as I mentioned. I just click on the XStoryPlayer.exe at the bottom and it launches just fine for me.

I do use Oculus Rift, so there is a possible difference. However, Rift users still have to use the Vive patch to play because the rift patch doesnt work. Basically, if you installed XSP 3.5 and the vive patch through the manager, we should be running the same game and version. If your folder looks just like the image here, and it still doesnt run, Then I apologize because I dont see a reason it would work for me but not for you.

Attachment:
temp.PNG
temp.PNG [ 10.61 KiB | Viewed 263 times ]


Fri Mar 15, 2019 3:12 am
Profile
Rank 6
Rank 6

Joined: Thu Feb 18, 2016 6:51 am
Posts: 25
Here's my folder. I removed some ddx files you don't have and it loads into the menus now, but when I try to load into a dungeon it crashes and Steam VR stops responding. I have a 4gb patch applied to the 32-bit exe. Think that might be the issue?


Attachments:
XSP 3.5 Folder.jpg
XSP 3.5 Folder.jpg [ 90.84 KiB | Viewed 252 times ]
Fri Mar 15, 2019 4:31 pm
Profile
Rank 6
Rank 6
User avatar

Joined: Sat Mar 02, 2019 5:57 am
Posts: 23
It is possible. At this point, anything that adds, removes or changes any file in the installation could be mucking things up.

Do you remember the version of the patch and where you got it? I have never run something like that with the game (at least not to my knowledge)
So I could try to get it and see if it breaks my game, or you could remove yours (or install another copy of the game in a new place) to test. Not sure what would be easier to try.


Fri Mar 15, 2019 7:28 pm
Profile
Rank 6
Rank 6

Joined: Thu Feb 18, 2016 6:51 am
Posts: 25
I got the patch here:

https://ntcore.com/?page_id=371

It's a good thing to have if you plan on running modded dungeons. Some of them require more RAM than the 32-bit exe allows. I think I will make a backup of my install and uninstall/reinstall to see if it will work.


Fri Mar 15, 2019 7:38 pm
Profile
Rank 6
Rank 6
User avatar

Joined: Sat Mar 02, 2019 5:57 am
Posts: 23
Yea thanks for that. It might help out alot if it doesnt turn out to be the reason. I get some hitching in my modded dungeon.
but I did just apply it and ran a dungeon and a the start of the story and I had no issues.

maybe there was just an issue with the install the first time and the reinstall will fix things...
here's to hoping


Fri Mar 15, 2019 7:48 pm
Profile
Rank 6
Rank 6

Joined: Thu Feb 18, 2016 6:51 am
Posts: 25
Ok, so I reinstalled and it worked. Then I put my patched exe back and it worked. Have to troubleshoot now to figure out what's causing the crash in my original install. Don't want to lose all my mods. lol


Fri Mar 15, 2019 7:54 pm
Profile
Rank 6
Rank 6

Joined: Thu Feb 18, 2016 6:51 am
Posts: 25
Fixed it. Turns out the problem was that I'm an idiot. I hadn't repatched the 32-bit exe after installing the VR update and it was running out of RAM because I have so many mods installed.


Fri Mar 15, 2019 8:17 pm
Profile
Rank 6
Rank 6
User avatar

Joined: Sat Mar 02, 2019 5:57 am
Posts: 23
aaahhh, ok.

no worries though. I have done some things that made me feel pretty dumb myself, as I am sure it happens to almost everyone. nevertheless, I am glad you got it to work. Have fun ;)


Fri Mar 15, 2019 9:59 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 103 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group.
Designed by X-Moon Productions.